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INTRODUCTION 

This document is presented to support GeoLearning clients in uploading 

Lectora® created courses using the Course Upload Tool in your Learning 

Center. 

SETTING UP SCORM AND AICC COURSES  

To make sure your course functions properly in a SCORM environment there 

are a couple actions you must perform prior to publishing the course. These 

actions can be performed at any time in the courseware creation process prior to 

publishing the course. 

 

The first step is to set your course up as an “AICC/SCORM/CourseMill” content 

type. 

1. Open your course in Lectora®. Please refer to the online documentation 

for assistance in creating a course. 

2. Right click on the Course Title icon  

3. From the menu, select Properties and click on the Content Tab. 
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4. In the Content Tab change Type of Title to AICC/SCORM/CourseMill 

and click OK. 

 

5. An icon labeled “AU” will be created. Right click on the  icon. 

6. Once in the Assignable Unit Properties, you will want to adjust a number 

of items. 

a. In the General section, change the AU name to the name of the 

course. Adjust the Page Size in Screen Pixels to your desired size 

or click on the Use Default choice. 

b. In the Assignable Unit Properties section, adjust the Description 

and Mastery Score as desired. The Mastery score should match 

the lowest passing score in your course assessment properties. 

We recommend that you set this to something about 70%. 

c. Click OK 
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Now that the course has been set up, the next step is adding a completion action. 

This action will tell the LMS that once a user has achieved the specified criteria, 

the course should be marked as completed. When adding this action into your 

course, you should pick the screen which corresponds with a successful course 

completion.  There are many ways to accomplish the actions listed below, but 

this represents our recommended approach. 

1. After locating your “successful completion screen,” right click on the 

screen icon and choose New -> Action. 

2. In the Action Properties General screen you will make a number of 

adjustments. 

a. Change the Action Name to “Lesson Completed”. 

b. Set On to “Show” 

c. Set Action to “Modify Variable” 

d. Set Target to “AICC_Lesson_Status” 

e. Set Value to “completed”.  

Note: This must NOT include quotes or capital letters. 

f. Set Modification Type to “Set Variable Contents” 
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3. In the Action Properties Condition screen you may want to adjust the 

settings so a completed status is not achieved unless another condition is 

met. Whether you choose to change this will depend on your course 

design. 

4. Last, you need to create an exit action. One way is to right click on the 

same page and then select add New -> Object -> Button.   

a. Once in the Button Properties click on the “On Click” tab. Set the 

Action to “Exit Title/Close Window”. 

 

Creating Courses with Larger Window Sizes 

By default your course will launch in a standard 800x600 window size. For your 

course design this may not be the most appropriate size. You might have end 

users with 1024x768 screens or larger and need to create content that utilizes 

more screen space without necessitating scroll bars. To accomplish this you will 
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need to add some JavaScript code to your course. Don’t worry though, adding it 

is quite simple. 

1. Once your course is open, right click on the Course Title and select New-

>Object->External HTML. 

2. Rename the Object Name to “Screen Resize”. 

3. Set Object Type to ““Other”. 

4. In the Custom HTML section copy or paste the JavaScript text into the 

dialogue box (see JavaScript Screen Resize Text) 

5. This text will resize your course window to the maximal available 

resolution on each person’s individual computer. While this may work in 

some cases, in others you will want to specify a certain size. To set the 

resize command to a 1024x768 for all users, change lines 2 and 3 of the 

JavaScript text to the following: 

 

a. var height = 768 

b. var width = 1024 

6. Once you have made the necessary adjustments, click on OK. These 

changes will work in the published version of the course. 
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Note: Checking Initially Visible is an optional choice. When the course is 

published the script will not be displayed even if this option is checked. 

JavaScript Screen Resize Text 

<script language=javascript>  

var width = 800 

var height = 600  

 

resizeBrowser(width,height);  

centerBrowser(width);  

 

function resizeBrowser(targetWidth,targetHeight){  

 

if (parseInt(navigator.appVersion)>3) { 

 if (navigator.appName=="Netscape") { 

  availableWidth = window.innerWidth-16; 

  availableHeight = window.innerHeight-16; 
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 } 

 if (navigator.appName.indexOf("Microsoft")!=-1) { 

  availableWidth = document.body.offsetWidth-20; 

  availableHeight = document.body.offsetHeight-20; 

 } 

} 

 

var diffWidth = targetWidth - availableWidth  

var diffHeight = targetHeight - availableHeight  

top.resizeBy(diffWidth, diffHeight);  

 

}  

 

function centerBrowser(targetWidth){  

var screenPosX = ((screen.availWidth - targetWidth)/2);  

var screenPosY = 0;  

top.moveTo(screenPosX, screenPosY);  

}  

 

</script> 

Note: This sample with slightly different code can also be found at: 

http://knowledgebase.trivantis.com/faqDspItem.asp?faqid=93 (the sample here does not work 

with FireFox) 

 

Adding Streaming Video  

When adding video files to your course you should make sure that all individual 

video files are less than 2MB in size. If they are larger than this, these videos 

should be placed on a streaming server. 

 

GeoLearning can provide you with streaming server hosting services if you do 

not already have this ability. (There are additional fees for this service based 

http://knowledgebase.trivantis.com/faqDspItem.asp?faqid=93
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upon size, usage, and security. Please contact your account manager for 

pricing.)   

The instructions provided below are based on you sending a Windows Media 

Video File (WMV) to GeoLearning and GeoLearning providing you with URL 

or location information, so please keep this in mind when using the examples. 

 

Unsecure Video 

In most cases it is not necessary to have a secure streaming server to stream your 

video content. While technically a user could obtain access to your video, this 

would require they correctly guess the URL and associated information.  

 

Adding a streaming video to your Lectora course is fairly simple. 

1. At the desired page select New -> Object -> Video 

2. Add a name for your video 

3. Select Windows Media Services Streaming Video  

4. In the URL add the URL provided to you by GeoLearning 

a. E.g., 

mms://geolearn.wmod.llnwd.net/a1117/o16/c/name/video.wmv 

5. Select the desired checkboxes and options and then click on OK 

At this point if you have entered the information the video will play successfully 

in your published course. 

 

Secure Video: Media Vault 

Security for streaming servers can operate on many levels. The GeoLearning 

hosted streaming service utilizes MediaVault. This tool will generate a dynamic 

URL that will become active upon generation and will expire shortly thereafter 

as well as verify the URL generation came from an approved server, thus 

preventing misuse. 
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Once you have provided the streaming video files to GeoLearning, you will be 

given a file path location for each of your videos: 

 e.g., acmeco/president.wmv 

This information will be used when adding the videos to your course. 

 

Adding this type of video requires a couple additional steps:  

1. First locate the page for the video and then select New -> Object -> 

External HTML 

2. In Object Name enter the name of your video 

3. In ObjectType select Other 

4. In the Custom HTML dialogue box enter the following information 

a. <IFRAME height="420" width="410" 

src="http://component.geolearning.com/securevideostreaming/se

cureform.aspx?object=folderName/videoFile.wmv&playerHeight

=400&playerWidth=400&showControls=1&autoStart=1" 

frameborder="0" scrolling="no"></IFRAME> 

b. There are 7 items that you will want to review and potentially 

adjust in this line: 

i. The height variable should be set to the pixel height of 

your movie + 20. So a movie that had a height of 400 

would be set to 420 for the height variable. 

ii. The width variable should be set to the pixel width of 

your movie + 10. So a movie that had a width of 400 

would be set to 410 for the width variable. 

iii. The object variable should be set to the video path and 

name that GeoLearning provides you. In other words, 

replace folderName/videoFile.wmv with the information 

GeoLearning provided you after the videos were loaded 

on the streaming server. 
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1. e.g., acme/president.wmv 

iv. The playerHeight variable should be set to the pixel 

height of your video. 

v. The playerWidth variable should be set to the pixel 

width of your video. 

vi. The showControls variable should be set to 0 if you do 

NOT want the video player controls to be displayed. 

vii. The autoStart variable should be set to 0 if you do NOT 

want the video to automatically start. 

5. Next, click on the Position and Size tab and then set the height and 

width settings to the same number you specified in the previous step for 

height and width variables. These will be the numbers that are 20 and 10 

pixels larger than your video size. 

6. Click on OK and then Publish your project.  

7. To view the video you MUST upload it your LMS first. If you do not, 

the course will play, but the video stream will not display due to the 

security restrictions. 
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PUBLISHING SCORM COURSES  

1. Open your course in Lectora®. Please refer to the online documentation 

for assistance in creating a course. 

2. In the Publish menu, select Publish to SCORM/Web-Based. 

a. If any errors were found in your course they will be listed in red. 

You will need to fix the errors before you can publish. 

3. Click the Publish button.  

4. The Publish SCORM Location dialog box will open. Enter the 

following information on the SCORM Options tab: 

a. Course Is: we recommend you select SCORM 1.2 Conformant. 

 SCORM 1.1 is also an option. 

 SCORM 1.0 and SCORM 2004 are not compatible with 

the Learning Center. 

b. Course Creator: Type the name you wish to display as the 

creator of the course material. 

 Note this is a required field, but it will not be passed to 

the Learning Center when you upload. 

 It is recommended to type the same name as you will 

use when uploading the course into the Learning Center. 
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c. Course ID: Type the ID of the course. 

 Note this is a required field, but it will not be passed to 

the Learning Center when you upload. 

 It is recommended to type the same ID you will use 

when uploading the course into the Learning Center. 

d. Course Title: Type the title of the course. 

 This course title will be the name of the course in the 

Learning Center once it is uploaded. 

 By default the name of the course will be displayed. It is 

recommended to keep this as the course title. This way 

the zip file that you upload is named the same as the 

course in the Learning Center. 

e. Course Description: Type a very brief description of the 

course’s content. 

 Note this is a required field, but you can leave it with 

the default text. The information will not be passed to 

the Learning Center when you upload. 

 

f. To automatically close the content window when exiting the 

course, check “The published course will be presented in a 
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separate window than the LMS” checkbox. This is highly 

recommended. 

g. Check/Uncheck “The published course will report Question 

and Test Interactions to LMS” checkbox.  

 GeoMaestro 4x does not support this feature. 

 If you are using GeoMaestro 5x and SCORM, you can 

check this option to track individual test items. 

h. To enable the automatic book-marking feature, check “The 

published course will prompt to restore the last viewed 

location within the LMS” checkbox. 

 

 

8. Click the Options tab, complete the following: 

a. Destination Folder: choose a local folder where your HTML 

files will be published.  

b. Select the desired publishing feature: 

 Publish Only Updated Pages/Resources: publish only 

the pages/resources that have been updated since last 

published. 
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 Publish All Pages/Resources in the Title: publish all 

the pages/resources regardless of whether they have 

been updated or not. 

 

c. Keep the defaults on the checkboxes. If you would like more 

information on these options please use the online help in 

Lectora. 

 

9. Click the OK button. The Publish dialog box will convert your files 

to HTML in the local folder specified above. 

10. Click the Done button. 

11. Upload the zip packaged to your LMS and test. 
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PUBLISHING AICC COURSES  

GeoMaestro LMS supports both SCORM and AICC standards. In some cases 

you may wish to upload your course in AICC format. If you choose to use AICC 

format you must follow the steps provided here in order to ensure your course 

launches and tracks properly. 

 

1. Open your course in Lectora®. Please refer to the online documentation 

for assistance in creating a course. 

2. Make sure you follow the appropriate steps in the Setting up SCORM 

and AICC Courses section of this guide. 

3. In the Publish menu, select Publish to AICC/Web-Based. 

a. If any errors were found in your course they will be listed in red. 

You will need to fix the errors before you can publish. 

4. Click the Publish button.  
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5. The Publish AICC Location dialog box will open. In the AICC 

Options tab you will need to make a few changes: 

 

a. Course Creator: Type the name you wish to display as the 

creator of the course material. 

i. Note this is a required field, but it will not be passed to 

the Learning Center when you upload. 

ii. It is recommended to type the same name as you will use 

when uploading the course into the Learning Center. 
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b. Course ID: Type the ID of the course. 

i. It is recommended to type the same ID you will use when 

uploading the course into the Learning Center. 

c. Course Title: Type the title of the course. 

i. This course title will be the name of the course in the 

Learning Center once it is uploaded. 

ii. By default the name of the course will be displayed. It is 

recommended to keep this as the course title. This way 

the zip file that you upload is named the same as the 

course in the Learning Center. 

d. Course Description: Type a very brief description of the 

course’s content. 

i. Note this is a required field, but you can leave it with the 

default text. The information will not be passed to the 

Learning Center when you upload. 

e. AICC courses can be published on different networks. In this 

case, check “The published course will reside on the same 

network server as the LMS” checkbox. 

f. To automatically close the content window when exiting the 

course, check “The published course will be presented in a 

separate window than the LMS” checkbox. This is highly 

recommended, but may not be required in your environment. 

Please test if you do not use the recommended option. 

g. Uncheck “The published course will report Question and Test 

Interactions to LMS” checkbox. 

i. Currently the Learning Center will not support this 

feature. 
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h. To enable the automatic book-marking feature, check “The 

published course will prompt to restore the last viewed 

location within the LMS” checkbox. 

6. Click the Options tab, complete the following: 

a. Destination Folder: choose a local folder where your HTML 

files will be published.  

b. Select the desired publishing feature: 

i. Publish Only Updated Pages/Resources: publish only 

the pages/resources that have been updated since last 

published. 

ii. Publish All Pages/Resources in the Title: publish all the 

pages/resources regardless of whether they have been 

updated or not. 

 

iii. Keep the defaults on the checkboxes, but do NOT check 

“Store Published Title in a Zip File” as you will need to 

make some modifications before zipping the package.  

 

If you would like more information on these options 



 

Publishing with Lectora® 

For GeoMaestro LMS 

 

 

 19 

please use the online help in Lectora. 

 

12. Click the OK button. The Publish dialog box will convert your files 

to HTML in the local folder specified above. 

13. Click the Done button. 

14. Lectora publishes some necessary AICC files in a folder called CRS 

in the published course folder. To load your Lectora AICC course 

into GeoMaestro you will need to make some modifications to these 

files before loading your AICC package. 

i. Access the folder you published your AICC course to, and 

locate the file with the extension “.au”.  If you have 

extensions turned off in Windows you may need to turn them 

on to more easily locate this file. 

 

To turn on the display of extension, open Windows Explorer 

and select Tools ->Folder Options 
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Click on the View tab and uncheck the “Hide extensions for 

known file types” option. Click on Ok and the extensions will 

now appear. 

 

 

The file you are looking for is located in the crs folder 

 



 

Publishing with Lectora® 

For GeoMaestro LMS 

 

 

 21 

ii. You must now make a small edit to this file. To edit this file 

right click on the file and choose Open with and then select 

Notepad. Alternatively you may have to launch Notepad 

first and then open the file from within Notepad if the Open 

with option is not available on your computer. 

 

 

Once the file is open, look through the 3-4 lines of text and 

locate the starting HTML file.  Alternatively you may want to 

use the search functionality in Notepad to search for “html” 

to more easily locate this text.  

 

It will be the only html file name in the code.  In the sample 

below it is a001index.html. 
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Now that you have located the file, remove the “../” that is in 

front of the file. In the example above it will be changed from 

“../a001index.html” to “a001index.html”. 

 

Exit Notepad and save the file you modified. 

iii. If you are using GeoMaestro 5x, zip the contents of the 

course including all directories and the recently modified file. 

Do NOT include the course folder in the zip file. The zip 

MUST have the main course contents at the root of the zipped 

file. 

iv. Upload the zip package to your LMS and then test. 

 

 NOTE: GeoMaestro 4x users, in addition to the previous steps you 

must also: 

i. Copy all 4 AICC files located in the CRS folder into the root 

directory of your course.  

ii. Rename the 4 files in the AICC package. Rename your *.des, 

*.cst, *.crs, and *.au files to hacp.des, hacp.cst, hacp.crs, and 

hacp.au respectively. It will not matter what their names were 
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before, the names you rename them to will always be the 

same. 

Zip up the package and upload the zipped package to your LMS. When 

uploading the package, specify the type as AICC HACP and then test. 
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Features 

 The zip file that is created when you publish is what you will upload into 

the Learning Center. Please refer to the Course Upload Tool 

documentation for instructions. 

 The course structure files will be created in a sub-directory of where 

your title resides called XML (if you published to SCORM). 

 For SCORM courses, the IMS Content Packaging manifest 

(imsmanifest.xml) will be created in the HTML folder.  The manifest 

will contain the first page of the course along with each page and the 

dependencies of each page. 

 Validates course materials for compliance with the SCORM or AICC 

standards. 

 Allows production of content that is either AICC, SCORM 1.0, SCORM 

1.1, SCORM 1.2, or SCORM 2004 conformant. Remember that only 

AICC or SCORM 1.2 can be loaded into the Learning Center. 

Restrictions 

 Only tests that can be scored may be included in a course. This 

necessitates that Short Answer and Essay questions are excluded from all 

tests. 

 Standalone questions are still permitted within the course. 

 Multiple tests may be included in the course. The sum of all test scores 

represents the maximum score for the course. 

 A course must contain at least one Exit Title action. See Adding Actions 

for more information. 

 A course may contain no tests, but then the score for the course will be 

automatically set to 100 on any page where the Exit Title action resides. 

 

 

 

 

 



 

 

 

 

 


